Import a sql dump file (db schema and data) Failed


#1

I’m trying to import a sql dump file (db schema and data) using the command

mysql --host=127.0.0.1 --user=root --port=xxxx --database=MYMEMDB_NAME < MYDUMPFILEPATH/MYDUMPFILE.SQL

and I received the error:

ERROR 1712 (HY000) at line xxxxx: Leaf Error (127.0.0.1:3307): Memory used by MemSQL (1088.62 Mb) has reached the ‘maximum_memory’ setting (1782 Mb) on this node. Possible causes include (1) available query execution memory has been used up for table memory (in use table memory: 78.62 Mb) and (2) the query is large and complex and requires more query execution memory than is available (in use query execution memory 0.00 Mb). See https://docs.memsql.com/troubleshooting/latest/memory-errors for additional information.


#2

As the error message says, MemSQL ran out of memory while loading your data. How large is the dataset you are trying to load?

Your memory limit is 1.8 GB, which is less than the minimum of 8 GB (https://docs.memsql.com/installation/v6.7/system-requirements/#hardware-and-software-requirements). As discussed on https://docs.memsql.com/troubleshooting/latest/troubleshooting/#my-hosts-have-less-than-minimum-memsql-system-requirements-how-can-i-make-memsql-run-on-those-hosts, running MemSQL with less than 8 GB memory is not recommended and could lead to a less ideal experience.


#3

The dataset is almost 7GB.
I also tried to import the tables one after another and worked out for the first one (with the smallest volume) but not with the second one (21,5MB)…