Docker cluster-in-a-box with no Leaf


#1

Hello everyone,

I’m running in a very awkward issue, with the lastest MemSQL Docker cluster-in-a-box container.

We deployed today the container on a local server on-premise where we have already a bunch of other docker containers like Kafka, Zookeeper, Neo4j, using Docker Compose. (We don’t have Kubernetes yet).

As we have a lot of ports in use we decided to make this switch with the default ports:

  • MemSQL Studio - from 8080 to 32796
  • Aggregator - from 3306 to 32798
  • Leaf - from 3307 to 32797

We managed to deploy the container without issues, using the steps from the official documentation.

Once deployed we found out that we don’t have any Leaf running (see the pictures attached).

https://drive.google.com/file/d/17FPXqY7Vsna6RC9moa73sxRjPMk2fshN/view?usp=sharing
https://drive.google.com/file/d/1vJUs0atPlLg_w4XcFQczxQgbWHd_Ih2D/view?usp=sharing

I tried to add a leaf by command but I got the error message saying that this is a free edition and I cannot add more leaves.

We tried to remove and add again the container but we end up in the same situation.

Please help/advise.

Kind Regards,
Adrian


#2

Please check the logs from the cluster-in-a-box container. You should be able to do this via docker-compose logs <service name>. I believe that if you check the logs you may see some errors similar to the one you received when you tried to add the leaf manually.

The issue is related to licensing and how we compute usage. Unfortunately, since you are using a unit based license - the machine running MemSQL needs to be smaller than 128GB of RAM and 32 cores. If the machine running MemSQL is larger in either metric then add leaf will fail.

Sorry about this - I am reaching out internally to determine if we can provide a work around. In the meantime can you confirm that this is indeed your issue?


#3

Hi Carl,

Thank you for your insight. This is something new for me to find out.

We can definitely check the logs, but I think the issue come from the fact that the MemSQL Docker container was deployed on a very powerful server (192 CPU Cores, 1TB Memory), and that’s why the leaf cannot be added.

Are there any workarounds to make this work on the current server?


#4

Unfortunately with the license that you have this is not possible. That said, we have another free license type which would work for your case - if you are interested please PM me the email address you used to sign up for your portal.memsql.com account.