Download Memsql server older version package

Hi,

I am only able to download the latest version 6.8 from here. But I do need to install 6.7.18.
Can you please share the link for downloading the lower version of memsql server RPM package.

Hi,
You can find 6.7.18 RPM package for memsql-server here: https://release.memsql.com/production/rpm/x86_64/memsql-server-6.7.18-db1caffe94.x86_64.rpm

Hey @prathyusha559,

You can leverage yum to install other versions of the memsql-server package.

$ yum search memsql-server
Loaded plugins: fastestmirror, ovl
Loading mirror speeds from cached hostfile
 * base: linux.mirrors.es.net
 * extras: sjc.edge.kernel.org
 * updates: linux.mirrors.es.net
================================================================================================================= N/S matched: memsql-server =================================================================================================================
memsql-server6.5.10-11746307b3.x86_64 : MemSQL + memsqlctl
memsql-server6.5.10-44458de9d1.x86_64 : MemSQL + memsqlctl
memsql-server6.5.11-db788fadca.x86_64 : MemSQL + memsqlctl
memsql-server6.5.14-9d287fac01.x86_64 : MemSQL + memsqlctl
memsql-server6.7.0-6ea98cecdf.x86_64 : MemSQL + memsqlctl
memsql-server6.7.0-97f4a09591.x86_64 : MemSQL + memsqlctl
memsql-server6.7.0-b14aff17fb.x86_64 : MemSQL + memsqlctl
memsql-server6.7.1-146ae8d333.x86_64 : MemSQL + memsqlctl
memsql-server6.7.1-e823135f6e.x86_64 : MemSQL + memsqlctl
memsql-server6.7.10-e69057eaa4.x86_64 : MemSQL + memsqlctl
memsql-server6.7.11-5d2517b77a.x86_64 : MemSQL + memsqlctl
memsql-server6.7.12-650d669b35.x86_64 : MemSQL + memsqlctl
memsql-server6.7.13-6478b355a8.x86_64 : MemSQL + memsqlctl
memsql-server6.7.14-fa416b0a53.x86_64 : MemSQL + memsqlctl
memsql-server6.7.15-d4450c6798.x86_64 : MemSQL + memsqlctl
memsql-server6.7.16-55671ba478.x86_64 : MemSQL + memsqlctl
memsql-server6.7.17-1e098df4f9.x86_64 : MemSQL + memsqlctl
memsql-server6.7.18-db1caffe94.x86_64 : MemSQL + memsqlctl
memsql-server6.7.19-ad08ef22e6.x86_64 : MemSQL + memsqlctl
memsql-server6.7.2-7e30b698e9.x86_64 : MemSQL + memsqlctl
memsql-server6.7.20-f64a25f384.x86_64 : MemSQL + memsqlctl
memsql-server6.7.3-381c9eee8a.x86_64 : MemSQL + memsqlctl
memsql-server6.7.4-26dc6d6439.x86_64 : MemSQL + memsqlctl
memsql-server6.7.5-9a97c304ea.x86_64 : MemSQL + memsqlctl
memsql-server6.7.6-841eb693c0.x86_64 : MemSQL + memsqlctl
memsql-server6.7.7-7669a637ba.x86_64 : MemSQL + memsqlctl
memsql-server6.7.8-a5a87c0575.x86_64 : MemSQL + memsqlctl
memsql-server6.7.9-7f441d7ccd.x86_64 : MemSQL + memsqlctl
memsql-server6.8.1-d3d220c272.x86_64 : MemSQL + memsqlctl
memsql-server6.8.2-f6e0fb9bc9.x86_64 : MemSQL + memsqlctl

Then, install your desired version with:

$ yum install memsql-server6.7.18-db1caffe94.x86_64
$ memsqlctl version
Version: 6.7.18

Hope that helps!

1 Like

Thanks for the solutions, that helps.